Thursday, September 17, 2015

Binary Addition (KICTM Uitm Jasin 2015)

Adding binary numbers is a very simple task, and very similar to the longhand addition of decimal numbers. As with decimal numbers, you start by adding the bits (digits) one column, or place weight, at a time, from right to left. Unlike decimal addition, there is little to memorize in the way of rules for the addition of binary bits:

0 + 0 = 0 
1 + 0 = 1 
0 + 1 = 1 
1 + 1 = 10 
1 + 1 + 1 = 11

Just as with decimal addition, when the sum in one column is a two-bit (two-digit) number, the least significant figure is written as part of the total sum and the most significant figure is “carried” to the next left column. Consider the following examples:

           
                11 1 --- Carry bits -----   11
  1001101     1001001                    1000111
+ 0010010   + 0011001                  + 0010110
 ---------   ---------                  ---------
  1011111     1100010                    1011101 


The addition problem on the left did not require any bits to be carried, since the sum of bits in each column was either 1 or 0, not 10 or 11. In the other two problems, there definitely were bits to be carried, but the process of addition is still quite simple.

INPUT
The first line of input contains an integer N , (1<=N<=1000) , which is the number of binary addition problems that follow. Each problem appears on a single line containing two binary values separated by a single space character. The maximum length of each binary value is 80 bits (binary digits). Note: The maximum length result could be 81 bits (binary digits).

OUTPUT
For each binary addition problem, print the problem number, a space, and the binary result of the addition. Extra leading zeroes must be omitted.

Sample Input 
3
1001101 10010
1001001 11001
1000111 1010110

Sample Output 
1 1011111
2 1100010
3 10011101


 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
import java.util.*;
import java.lang.*;
import java.math.*;

public class Q2{
   public static void main(String[] args){
      Scanner scan = new Scanner(System.in);
      
      String line = System.getProperty("line.separator");
      scan.useDelimiter(line);
      
      int cases = scan.nextInt();
      
      String [] ans = new String[cases];
      
      for(int x=0;x<cases;x++){
         String[] get = scan.next().split(" ");
         
         long val1 = Long.parseLong(get[0],2);
         long val2 = Long.parseLong(get[1],2);
         
         long sum = val1+val2;
         
         ans[x] = ""+Long.toBinaryString(sum);
      }
      
      for(int x=0;x<cases;x++){
         System.out.println((x+1)+" "+ans[x]);
      }
   }
}

No comments:

Post a Comment